Reconectare wi-fi dupa resume in Ubuntu 16.04

In Ubuntu 16.04 cand deschid laptop-ul (resume din suspend/sleep) nu se mai reconecteaza la reteaua WiFi. Pentru a forta o reinitializare a serviciului de retea NetworManager se poate crea un serviciu systemd prin care dupa suspend/sleep se restarteaza NetworkManager. Mai jos sunt pasii prin care poti face acest lucru:

Pasul 1. Creeaza serviciul systemd wifi-resume.service
sudo vi /etc/systemd/system/wifi-resume.service
cu continutul:
#/etc/systemd/system/wifi-resume.service
[Unit]
Description=Restart NetworkManager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target
[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service
[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Pasul 2. Activare serviciu
Din linia de comanda
sudo systemctl enable wifi-resume.service

Pasul 3. Testare
Pliaza laptop-ul asteapta 2 secunde sa intre in suspend apoi redeschide laptop-ul. Icoana de retea ar trebui sa iti arate cum incepe sa caute conexiunea WiFi si eventual sa se conecteze.

Pachete orfane in urma actualizarii la Ubuntu 11.04

Dupa o instalare de Ubuntu 10.04 LTS, am fost nevoit sa fac un upgrade la ultima versiune de Ubuntu. Instalarea noii versiuni a fost un succes cu exceptia unor mici probleme pe care am reusit sa le rezolv ulterior.
Ce m-a deranjat cel mai tare a fost faptul ca in Synaptic au ramas inregistrari de configurari a unor pachete din versiunea anterioara care nu au putut fi curatate prin simpla lor selectare si stergere folosind interfata Synaptic.
Drept urmare am instalat dintr-un terminal aptitude :

cosming@cosming-desktop:~$ sudo apt-get install aptitude

si apoi :

cosming@cosming-desktop:~$ aptitude -F %p search ‘~c’ | xargs sudo dpkg -P

Yahoo Messenger linux – nu mai functioneaza

Yahoo! nu mai suporta protocolul de comunicatie vechi, aplicatiile de mesagerie pe linux se pare ca se bazau pe aceste versiuni

De câteva zile se pare că serviciul de mesagerie online Yahoo! nu se mai poat accesa de pe sistemele de operare linux prin deja arhicunoscutele: gaim, pidgin, kopete.

Yahoo! nu mai suportă versiuni ale protocolul de comunicație vechi (folosite pana în versiunea 7.5 a Yahoo! Messenger); toate aplicațiile de mesagerie pe linux se pare că foloseau aceste versiuni ale protocolului.

Așteptăm cu nerăbdare ca comunitățile open source să „rezolve” aceste probleme; în acest timp se poate folosi serviciul de mesagerie Yahoo pe web.